[Python-Dev] defaultdict and on_missing()
Guido van Rossum
guido at python.org
Sun Feb 26 00:16:21 CET 2006
FWIW this has now been checked in. Enjoy!
On 2/23/06, Guido van Rossum <guido at python.org> wrote:
> On 2/22/06, Michael Chermside <mcherm at mcherm.com> wrote:
> > A minor related point about on_missing():
> > Haven't we learned from regrets over the .next() method of iterators
> > that all "magically" invoked methods should be named using the __xxx__
> > pattern? Shouldn't it be named __on_missing__() instead?
> Good point. I'll call it __missing__. I've uploaded a new patch to
--Guido van Rossum (home page: http://www.python.org/~guido/)
More information about the Python-Dev