[Python-Dev] decorator module patch

Raymond Hettinger raymond.hettinger at verizon.net
Sun Mar 12 23:03:58 CET 2006

[Nick Coghlan]
> I agree it makes sense to have "decorator", "memoize", "deprecated" and
> "partial" all being members of the same module, whether the name be
> "functools" or "functional" (although I have a slight preference for
> "functools" due to the parallel with "itertools").

I like "functools" for a different reason -- the name is sufficiently broad so 
that we don't have fret about whether a particular tool fits within the module's 
scope.  In contrast, a name like "functional" suggests that some of these tools 
don't quite fit.


More information about the Python-Dev mailing list