[Python-Dev] Remove METH_OLDARGS?

Georg Brandl g.brandl at gmx.net
Sun May 28 09:02:15 CEST 2006

In the process of reviewing and possibly extending getargs.c, I stumbled
over the "compatibility" flag supposedly used for METH_OLDARGS functions.
No code in the core uses this calling convention any more, and it has been
deprecated for quite a long time (since 2.2), so would it be appropriate to end
support for it in 2.5?


More information about the Python-Dev mailing list