[Python-Dev] Massive test_sqlite failure on Mac OSX ... sometimes

skip at pobox.com skip at pobox.com
Fri Oct 20 22:04:55 CEST 2006

I'm setting up a buildbot slave for sqlalchemy on one of my Macs at home.
When it builds and tests Python's test suite the sqlite test fails.  When I
ran it alone like this:

    ./python.exe Lib/test/test_sqlite.py


    ./python.exe Lib/test/regrtest.py test_sqlite

it succeeded.  When I ran the full test suite it failed.  I then tried
adding -v as the error message suggested.  It hung in test_pty waiting for a
child process to complete.  (Is this a known problem?)  I finally redirected
stdout and stderr like so:

    ./python.exe Lib/test/regrtest.py -l -v > test.out 2>&1

and it completed.  It failed 146 out of 167 tests.  Here is a sample of the
failure messages:

    CheckClose (sqlite3.test.dbapi.ConnectionTests) ... ERROR
    CheckCommit (sqlite3.test.dbapi.ConnectionTests) ... ERROR
    CheckCommitAfterNoChanges (sqlite3.test.dbapi.ConnectionTests) ... ERROR
    CheckCursor (sqlite3.test.dbapi.ConnectionTests) ... ERROR
    CheckExceptions (sqlite3.test.dbapi.ConnectionTests) ... ERROR
    CheckFailedOpen (sqlite3.test.dbapi.ConnectionTests) ... ERROR
    CheckRollback (sqlite3.test.dbapi.ConnectionTests) ... ERROR
    CheckRollbackAfterNoChanges (sqlite3.test.dbapi.ConnectionTests) ... ERROR
    CheckArraySize (sqlite3.test.dbapi.CursorTests) ... ERROR
    CheckClose (sqlite3.test.dbapi.CursorTests) ... ERROR
    CheckCursorConnection (sqlite3.test.dbapi.CursorTests) ... ERROR
    CheckCursorWrongClass (sqlite3.test.dbapi.CursorTests) ... ERROR
    CheckExecuteArgFloat (sqlite3.test.dbapi.CursorTests) ... ERROR
    CheckExecuteArgInt (sqlite3.test.dbapi.CursorTests) ... ERROR
    CheckExecuteArgString (sqlite3.test.dbapi.CursorTests) ... ERROR
    CheckExecuteDictMapping (sqlite3.test.dbapi.CursorTests) ... ERROR
    CheckExecuteDictMappingNoArgs (sqlite3.test.dbapi.CursorTests) ... ERROR
    CheckExecuteDictMappingTooLittleArgs (sqlite3.test.dbapi.CursorTests) ... ERROR
    CheckExecuteDictMappingUnnamed (sqlite3.test.dbapi.CursorTests) ... ERROR
    CheckExecuteIllegalSql (sqlite3.test.dbapi.CursorTests) ... ERROR
    CheckExecuteManyGenerator (sqlite3.test.dbapi.CursorTests) ... ERROR
    CheckExecuteManyIterator (sqlite3.test.dbapi.CursorTests) ... ERROR
    CheckExecuteManyNotIterable (sqlite3.test.dbapi.CursorTests) ... ERROR

A quick check of the tracebacks shows all the errors are of this form
(CheckClose is the first failure):

    ERROR: CheckClose (sqlite3.test.dbapi.ConnectionTests)
    Traceback (most recent call last):
      File "/Library/Buildbot/pybot/trunk.montanaro-g5/build/Lib/sqlite3/test/dbapi.py", line 85, in setUp
        self.cx = sqlite.connect(":memory:")
    ProgrammingError: library routine called out of sequence

That is, they all raise the same exception and all exceptions are raised on
sqlite.connect(":memory:") calls.  Sometimes there is a second parameter to
the call.

Anybody seen this before?


More information about the Python-Dev mailing list