[Python-Dev] deprecate commands.getstatus()

Greg Ewing greg.ewing at canterbury.ac.nz
Fri Mar 23 02:24:17 CET 2007

Titus Brown wrote:

>  * second, I'd like to add a 'require_success' bool keyword, that is
>    by default False (and does nothing in that case).  However, when
>    True, the functions would emulate check_call, i.e. they would raise
>    CalledProcessError when the returncode was not zero.

By the no-constant-parameters principle, I think it would
be better to have another set of functions for this. They
should be named without 'status' in the names, since if the
function returns at all, the status is always going to be


More information about the Python-Dev mailing list