[Python-Dev] Unable to commit

Georg Brandl g.brandl at gmx.net
Sun May 27 01:02:31 CEST 2007

Neal Norwitz schrieb:
> On 5/26/07, Peter Åstrand <astrand at cendio.se> wrote:
>> I'm unable to commit tonight:
>> Sending        Doc/lib/libsubprocess.tex
>> Sending        Lib/subprocess.py
>> Sending        Lib/test/test_subprocess.py
>> Transmitting file data ...svn: Commit failed (details follow):
>> svn: 'pre-commit' hook failed with error output:
>> Traceback (most recent call last):
>>   File "/data/repos/projects/hooks/checkwhitespace.py", line 50, in ?
>>     run_app(main)
>>   File "/usr/lib/python2.3/site-packages/svn/core.py", line 33, in run_app
>>     return apply(func, (pool,) + args, kw)
>>   File "/data/repos/projects/hooks/checkwhitespace.py", line 32, in main
>>     if fs.node_prop(txn_root, path, 'svn:special') == '*': continue
>> TypeError: svn_fs_node_prop() takes exactly 4 arguments (3 given)
>> Any ideas?
> I tried to fix it so you can check in links, but that didn't work.  I
> commented out the change, so you should be able to commit again.

Odd... the call worked here (SVN 1.4.3). Which version is the server using?


Thus spake the Lord: Thou shalt indent with four spaces. No more, no less.
Four shall be the number of spaces thou shalt indent, and the number of thy
indenting shall be four. Eight shalt thou not indent, nor either indent thou
two, excepting that thou then proceed to four. Tabs are right out.

More information about the Python-Dev mailing list