[Python-Dev] Proposed unittest changes
fuzzyman at voidspace.org.uk
Thu Apr 17 18:20:49 CEST 2008
Jesse Noller wrote:
> On Thu, Apr 17, 2008 at 10:59 AM, Michael Foord
> <fuzzyman at voidspace.org.uk> wrote:
>> Guido van Rossum wrote:
>> > I'm worried that a mass renaming would do anything but inconvenience
>> > users during the already stressful 2->3 transition.
>> > I'm more in favor of the original proposal of reducing the redundancy post-3.0.
>> So nix the PEP-8'ifying until after 3.0.
>> So new methods should follow the current naming scheme (assertIn,
>> assertNotIn etc).
> +1 on your changes Michael - I really like the decorator idea. Let me
> know if you want help on adding the new stuff or updating the
> documentation. What about aiming this at 2.6 instead of 3.0?
As they will just be new features rather than API changes I would like
to add these to 2.6 - although I think May 10th may be after the last
More information about the Python-Dev