[Python-Dev] Proposed unittest changes

Steve Holden steve at holdenweb.com
Tue Jul 15 09:04:58 CEST 2008

Thomas Lotze wrote:
> Ben Finney wrote:
>> I'd count this as another (minor) point in favour of making the 'fail*'
>> methods canonical: the names are consistent *and* gramatically sensible:
> -1
> I'm surprised nobody (that I've noticed) has brought up the point yet that
> test code is a lot easier to read if it makes positive assertions. When
> reading failure conditions, one has to constantly invert them in order to
> deduce the behaviour that is tested. failUnless and friends aren't better
> either IMO since while they do work with positive assertions, the method
> names themselves are doubly negative. assert* methods are so much more
> straightforward to comprehend.
I think this is where I came in.

Steve Holden        +1 571 484 6266   +1 800 494 3119
Holden Web LLC              http://www.holdenweb.com/

More information about the Python-Dev mailing list