[Python-Dev] PEP: Consolidating names and classes in the `unittest`module (updated 2008-07-15)
grflanagan at gmail.com
Wed Jul 16 02:12:02 CEST 2008
Ben Finney wrote:
> Nick Coghlan <ncoghlan at gmail.com> writes:
>> One option for rationalising the API would be to merely keep the
>> shortest version of each phrase (i.e. use assert* instead of
>> fail_unless* for the positive tests and fail_if* instead of
>> assert_not* for the negative tests, and always drop the trailing 's'
>> from 'equals').
> I think clarity, consistency, and discoverability are more important
> criteria than saving a few characters in a method name.
>> Adding in possible positive and negative forms of the proposed new
> A major point of this PEP is to *remove* redundant names in the API.
should be quite sufficient ;-)
More information about the Python-Dev