[Python-Dev] PEP: Frequently-requested additional features for the `unittest` module

Ben Finney ben+python at benfinney.id.au
Wed Jul 16 09:01:30 CEST 2008


Scott Dial <scott at scottdial.com> writes:

> I would argue to go even further:
> 
> assertEqual = assert_eq
> assertAlmostEqual = assert_almost_eq
> assertNotEqual = assert_ne
> assertNotAlmostEqual = assert_almost_ne
> 
> I'm not sure if there are others, but using the same abbreviations
> from operator is consistent and readable and short, in my opinion.

This doesn't seem to be a good fit for either of "Consolidate names in
unittest API" (which seeks to make the renames meet standards, not
find better names), nor "Frequently-requested additions to unittest"
(which seeks *only* to add functionality, not change existing names).

-- 
 \      “An expert is a man who has made all the mistakes which can be |
  `\                         made in a very narrow field.” —Niels Bohr |
_o__)                                                                  |
Ben Finney



More information about the Python-Dev mailing list