[Python-Dev] Running Py2.6 with the -3 option

engelbert gruber grubert at users.sourceforge.net
Wed Jul 16 20:18:59 CEST 2008

On Wed, Jul 16, 2008 at 7:02 PM, Guido van Rossum <guido at python.org> wrote:

> On Tue, Jul 15, 2008 at 11:50 PM, engelbert gruber
> <grubert at users.sourceforge.net> wrote:
>> I see mostly ``dict.has_key() not supported in 3.x;`` and sometimes
>> ``DeprecationWarning: callable() not supported in 3.x;`` .
> Good catch, Engelbert.
> But why would has_key() need a warning when 2to3 will fix it just fine?

for example, if has_key is the only problem in my module, it is
possible to support py22 to py3 with one source which i think would be
quite handy.

and for this the warning is great.

More information about the Python-Dev mailing list