[Python-Dev] PEP 371: Additional Discussion

Mike Klaas mike.klaas at gmail.com
Wed Jun 4 01:01:49 CEST 2008

On 3-Jun-08, at 3:53 PM, Benjamin Peterson wrote:

> On Tue, Jun 3, 2008 at 5:08 PM, Jesse Noller <jnoller at gmail.com>  
> wrote:
>> Also - we could leave in stubs to match the threading api - Guido,  
>> David
>> Goodger and others really prefer not to continue the "broken" API  
>> of the
>> threading API
> I agree that the threading the the pyprocessing APIs should be PEP 8
> compliant, but I think 2 APIs is almost worse than one wrong one.

A cleaner way to effectuate the transition would be to leave the  
camelCase API in 2.6 (for both modules), switch to PEP 8 in py3k (for  
both modules), and provide threading3k and multiprocessing3k modules  
in 2.6 that façade the 2.6 API with the PEP 8 API.

2to3 would rewrite 'import threading3k' to 'import threading' and  
everything would work (it would warn about 'import threading' in 2.6  


More information about the Python-Dev mailing list