[Python-Dev] [Python-3000] xturtle and 3.0

Paul Moore p.f.moore at gmail.com
Mon Mar 17 22:03:58 CET 2008


On 17/03/2008, Gregor Lingl <gregor.lingl at aon.at> wrote:
>  as you probably can imagine, I'd like to try out xturtle.py with Python 2.6
>  Alas, I didn't succeed installing Python 2.6 correctly on my Windows
>  machine using  the Windows msi installer.
>
>  Whereas I could start the python interpreter successfully it was
>  impossible to use it to execute either idle.py nor turtle.py

It worked for me. I have Python 2.5 installed, so I did an install of
Python 2.6a1 "for all users", but I deselected the "register
extensions" option (which makes this the default Python).

I then ran idle using

    C:\Apps\Python26\python C:\Apps\Python26\Lib\idlelib\idle.py

This worked fine for me.

>  A look on sys.path showed the DLLs directory to be present there.
>  Do you have an explanation for this behaviour? What can I do to
>  avoid it? Do I have to take some special action when installing the
>  alpha release (I did it "for this user only")?

This is my sys.path:

>C:\Apps\Python26\python
Python 2.6a1 (r26a1:61155, Mar  1 2008, 12:11:56) [MSC v.1500 32 bit
(Intel)] on win32
Type "help", "copyright", "credits" or "license" for more information.
>>> import sys
>>> sys.path
['', 'C:\\Apps\\Python26\\python26.zip', 'C:\\Apps\\Python26\\DLLs',
'C:\\Apps\\Python26\\lib', 'C:\\Apps\\Python26\\lib\\plat-win',
'C:\\Apps\\Python26\\lib\\lib-tk', 'C:\\Apps\\Python26',
'C:\\Apps\\Python26\\lib\\site-packages']

I don't see why "for this user only" should work any differently. No,
I just tried it and it's OK as well. I can't see any reason why
"register extensions" sould cause you a problem either.

Can I suggest you uninstall and reinstall and see if that helps? Keep
a log of what you didn, and if it's still a problem let me know and
I'll see what I can do.

Paul.

PS What version of Windows are you on? I'm using XP Home (32 bit). If
you're using 64-bit, I can't help, I'm afraid...


More information about the Python-Dev mailing list