[Python-Dev] 3.1 focus (was Re: for __future__ import planning)

Antoine Pitrou solipsis at pitrou.net
Sat Oct 4 12:36:41 CEST 2008

Martin v. Löwis <martin <at> v.loewis.de> writes:
> > This may be more complicated than it sounds, because you'd probably
> > add a very general requirement-indicating feature to PyPI, not merely
> > a 'supports 3.0' Boolean on each record, and requirements are actually
> > pretty complicated: alternative packages, specific version numbers...
> Can you propose a spec?

Setuptools already has a syntax for declaring requirements.

More information about the Python-Dev mailing list