[Python-Dev] #!/usr/bin/env python --> python3 where applicable

Michael Foord fuzzyman at voidspace.org.uk
Mon Apr 20 20:24:30 CEST 2009


Jared Grubb wrote:
>
> On 19 Apr 2009, at 02:17, Stephen J. Turnbull wrote:
>> Nick Coghlan writes:
>>> 3. Change the shebang lines in Python standard library scripts to be
>>> version specific and update release.py to fix them all when bumping the
>>> version number in the source tree.
>>
>> +1
>>
>> I think that it's probably best to leave "python", "python2", and
>> "python3" for the use of downstream distributors.  ISTR that was what
>> Guido concluded, in the discuss that led to Python 3 defaulting to
>> altinstall---it wasn't just convenient because Python 3 is a major
>> change, but that experience has shown that deciding which Python is
>> going to be "The python" on somebody's system just isn't a decision
>> that Python should make.
>
> Ok, so if I understand, the situation is:
> * python points to 2.x version
> * python3 points to 3.x version
> * need to be able to run certain 3k scripts from cmdline (since we're 
> talking about shebangs) using Python3k even though "python" points to 2.x
>
> So, if I got the situation right, then do these same scripts 
> understand that PYTHONPATH and PYTHONHOME and all the others are also 
> probably pointing to 2.x code?
IIRC the proposal was to also create PYTHON3PATH and PYTHON3HOME.

Michael

>
> Jared
> _______________________________________________
> Python-Dev mailing list
> Python-Dev at python.org
> http://mail.python.org/mailman/listinfo/python-dev
> Unsubscribe: 
> http://mail.python.org/mailman/options/python-dev/fuzzyman%40voidspace.org.uk 
>


-- 
http://www.ironpythoninaction.com/
http://www.voidspace.org.uk/blog




More information about the Python-Dev mailing list