[Python-Dev] VC++ versions to match python versions?

Chris Withers chris at simplistix.co.uk
Mon Aug 17 17:21:34 CEST 2009

John Arbash Meinel wrote:
> Guppy doesn't compile on Windows. Pretty much full-stop. It uses static
> references to DLL functions, which on Windows is not allowed.

This is no longer true as of the latest version of guppy...

> I've tried patching it to remove such things, and I finally got it to
> compile, only to have it go "boom!" in actual use.
> If you can get it to work, certainly post something so that I can cheer.

Are you on the guppy list? Someone posted a patch to it (which may have 
been you?) which has made it into the latest release. I haven't tried to 
get it working myself yet, but John Machin (who maintains xlrd) has with 
the Express compiler. I was just checking I had the right version and 
what version I should use if I want to try with Python 2.5.

I also wanted to know what versions I should be using for python core 
development should I be foolhardy enough to try any of that on 
Windows... (he says, staring down the barrel of slow httplib downloads 
on Windows :'( )

Will let you know what I find...


Simplistix - Content Management, Batch Processing & Python Consulting
            - http://www.simplistix.co.uk

More information about the Python-Dev mailing list