[Python-Dev] Proposing PEP 345 : Metadata for Python Software Packages 1.2

david.lyon at preisshare.net david.lyon at preisshare.net
Mon Dec 28 01:15:49 CET 2009

> On Fri, Dec 25, 2009 at 8:33 AM, Nick Coghlan <ncoghlan at gmail.com> wrote:
>> Martin v. Löwis wrote:
> FYI we have introduced a range operator, so one may define a range of
> versions.
> This is useful for instance to write:
>   Requires-Python: ~=2.5
> Which means: requires any version of Python 2.5.x. This operator is
> the default operator,
> meaning that you can also write:
>   Requires-Python: 2.5

I don't like the ~ at all sorry. The ~ operator is thoroughly confusing.

No application developer will quickly figure out what a tilde means. Maybe
it means 'roughly', but it requires too much thought and is ambiguous. 2.5
is not roughly 2.5.2. It is the same exactly.

Before we had : Requires-Python: 2.5, 2.6

That made much more sense. It was simple and unambiguous, and is relevant
to typical packaging scenarios.

I hope we can go back to the original proposal.



More information about the Python-Dev mailing list