[Python-Dev] Proposing PEP 345 : Metadata for Python Software Packages 1.2
sridharr at activestate.com
Mon Dec 28 01:41:29 CET 2009
On 12/27/2009 4:15 PM, david.lyon at preisshare.net wrote:
>> On Fri, Dec 25, 2009 at 8:33 AM, Nick Coghlan<ncoghlan at gmail.com> wrote:
>>> >> Martin v. Löwis wrote:
>> > FYI we have introduced a range operator, so one may define a range of
>> > versions.
>> > This is useful for instance to write:
>> > Requires-Python: ~=2.5
>> > Which means: requires any version of Python 2.5.x. This operator is
>> > the default operator,
>> > meaning that you can also write:
>> > Requires-Python: 2.5
> I don't like the ~ at all sorry. The ~ operator is thoroughly confusing.
> No application developer will quickly figure out what a tilde means. Maybe
> it means 'roughly', but it requires too much thought and is ambiguous. 2.5
> is not roughly 2.5.2. It is the same exactly.
I am a bit confused at the current proposal combined with the newly
introduced range operator.
Would "Requires-Python: <=2.5" include 2.5.4 or not?
Also, "Requires-Python: 3" would include all 3.X versions, correct?
More information about the Python-Dev