[Python-Dev] Proposing PEP 345 : Metadata for Python Software Packages 1.2

Ben Finney ben+python at benfinney.id.au
Mon Dec 28 02:10:27 CET 2009

Tarek Ziadé <ziade.tarek at gmail.com> writes:

> FYI we have introduced a range operator, so one may define a range of
> versions. This is useful for instance to write:
>   Requires-Python: ~=2.5
> Which means: requires any version of Python 2.5.x.

-1 on that syntax. It's an extra operator, with a non-obvious meaning;
the meaning should be as clear as feasible even to those who have not
read the specification. The existing operators ‘>’, ‘>=’, ‘<’ ‘<=’ are
standard and more obvious.

That is, the existing operators:

    Requires-Python: >=2.5, <2.6

explicitly specify the range in your example.

 \           “Value your freedom or you will lose it, teaches history. |
  `\     “Don't bother us with politics,” respond those who don't want |
_o__)                               to learn.” —Richard Stallman, 2002 |
Ben Finney

More information about the Python-Dev mailing list