[Python-Dev] Proposing PEP 345 : Metadata for Python Software Packages 1.2

MRAB python at mrabarnett.plus.com
Mon Dec 28 02:21:07 CET 2009


Tarek Ziadé wrote:
> On Mon, Dec 28, 2009 at 1:41 AM, Sridhar Ratnakumar
> <sridharr at activestate.com> wrote:
> [..]
>> Tarek,
>>
>> I am a bit confused at the current proposal combined with the newly
>> introduced range operator.
>>
>> Would "Requires-Python: <=2.5" include 2.5.4 or not?
> 
> <=2.5 means any version that is inferior or equal to 2.5.0 so 2.5.4
> doesn't match
> 
>> Also, "Requires-Python: 3" would include all 3.X versions, correct?
> 
> Correct, because, "Requires-Python: 3" is equivalent to "Requires-Python: ~= 3"
> which is equivalent to "Requires-Python: 3.x.x"
> 
To me it's non-intuitive that "<=2.5" means <=2.5.0 but "2.5" means 
2.5.x; it's not consistent, explicit is better than implicit, etc.

I'd prefer it if omission means "don't care", so "2" means 2.x.y and
"2.5" means 2.5.x.


More information about the Python-Dev mailing list