[Python-Dev] Proposing PEP 345 : Metadata for Python Software Packages 1.2

Stephen J. Turnbull stephen at xemacs.org
Mon Dec 28 06:28:08 CET 2009


david.lyon at preisshare.net writes:

 > >> Before we had : Requires-Python: 2.5, 2.6
 > >>
 > >> That made much more sense. It was simple and unambiguous, and is
 > >> relevant to typical packaging scenarios.
 > >
 > > Unfortunately, it is fairly ambiguous, and makes no sense. It means
 > > "requires Python 2.5 *AND* requires Python 2.6", which is a requirement
 > > that no single version can meet.
 > 
 > No, it means a library requires either python 2.5 *OR* python 2.6 to be
 > installed properly.

If Martin and the SIG disagree on the interpretation (and I see
Martin's point: in ">=2.5, <2.6" the comma is a conjunction, not a
disjunction), that's too much ambiguity for me.

-1




More information about the Python-Dev mailing list