[Python-Dev] Proposing PEP 345 : Metadata for Python Software Packages 1.2

Tres Seaver tseaver at palladion.com
Mon Dec 28 06:20:12 CET 2009


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Tarek Ziadé wrote:
> On Mon, Dec 28, 2009 at 1:41 AM, Sridhar Ratnakumar
> <sridharr at activestate.com> wrote:
> [..]
>> Tarek,
>>
>> I am a bit confused at the current proposal combined with the newly
>> introduced range operator.
>>
>> Would "Requires-Python: <=2.5" include 2.5.4 or not?
> 
> <=2.5 means any version that is inferior or equal to 2.5.0 so 2.5.4
> doesn't match
> 
>> Also, "Requires-Python: 3" would include all 3.X versions, correct?
> 
> Correct, because, "Requires-Python: 3" is equivalent to "Requires-Python: ~= 3"
> which is equivalent to "Requires-Python: 3.x.x"
> 

Point of order:  what is the point of sending the discussion off to the
distutils SIG if we are just going to bikeshed it (again!) here.


Tres.
- --
===================================================================
Tres Seaver          +1 540-429-0999          tseaver at palladion.com
Palladion Software   "Excellence by Design"    http://palladion.com
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAks4QAwACgkQ+gerLs4ltQ5LJACfY9ijtkw/Bsyg2xXp93xNtbhy
QAUAnRBZWSMk+izGDEjVkHVLpu418gfR
=vM/V
-----END PGP SIGNATURE-----



More information about the Python-Dev mailing list