[Python-Dev] Proposing PEP 345 : Metadata for Python Software Packages 1.2

"Martin v. Löwis" martin at v.loewis.de
Mon Dec 28 11:42:50 CET 2009

>> So specifying 2.5 would be a short-hand for *what*?
> 2.5 would be a shorthand for 2.5.x. So, equivalent to : >=2.5.0, < 2.6.0

Ok, so it's not a shorthand for a single operator anymore, but for a
more complex term. Fine with me.

> 2.5.0 would be the notation required to describe this specific micro version.

I think it would be a shorthand for >=2.5.0, <2.5.1, right?

Or are you saying that specifying a version is sometimes a shorthand for
a range, and sometimes a shorthand for the == operator (i.e. one exact

> Requires-Dist: zope.interface (3.1)      ==> any versions that starts
> with 3.1, not including post- or pre- releases
> Requires-Dist: zope.interface (3.1.0)   ==> only 3.1.0

No, it should be: any version that starts with 3.1.0, not including
post- or pre-releases

> Requires-Python: 3                              ==> Python 3 (no
> matter wich one)

Almost: excluding pre- and post-releases.

> Requires-Python: >=2.6,<3                  ==> Any version of Python
> 2.6.x or 2.7.x (and 2.8.x if it exists one day)

This time, including pre- and post-releases, right?

> Requires-Python: 2.6.2                         ==> only Python 2.6.2

No: >=2.6.2, <2.6.3 (of course, the only Python release in that range
was 2.6.2, since there was no


More information about the Python-Dev mailing list