[Python-Dev] Proposing PEP 345 : Metadata for Python Software Packages 1.2

Lennart Regebro regebro at gmail.com
Mon Dec 28 11:57:57 CET 2009


On Mon, Dec 28, 2009 at 11:27,  <david.lyon at preisshare.net> wrote:
> What about going even more simple...
>
> Requires-Python: 2.5..3 3.1..

Doh! Of course. Works for me. In fact, the dots could be dashes as well.

Requires-Python: 2.5-3 3.1-

Commas, spaces, semicolons, whatever. We could allow:

Requires-Python: 2.5-3 3.1-
Requires-Python: 2.5-3,3.1-
Requires-Python: 2.5-3;3.1-
Requires-Python: 2.5..3, 3.1..

To be equivalent.

That syntax covers all reasonable usecases, as far as I can see, and is clear.

Requires-Python: 2.5.2-3 ,3.1.2, 3.2-

2.5.2 and up to, but not including, 3.0.0.
*or*
3.1.2
*or*
3.2.0 or later.

-- 
Lennart Regebro: http://regebro.wordpress.com/
Python 3 Porting: http://python-incompatibility.googlecode.com/
+33 661 58 14 64


More information about the Python-Dev mailing list