[Python-Dev] Proposing PEP 345 : Metadata for Python Software Packages 1.2

Lennart Regebro regebro at gmail.com
Mon Dec 28 12:02:05 CET 2009


On Mon, Dec 28, 2009 at 11:54, "Martin v. Löwis" <martin at v.loewis.de> wrote:
> This == operator is fairly common in Debian. For example, the apache2
> package installed on my system specifies

Oh, absolutely, but that's when you specify interdependencies between
packages. Nobody makes a Python package for generic use and say "you
should only use this with Python 2.5.0 and nothing else". Specifying
zope.interfaces 1.2.3 for zope.component 1.2.3 makes a lot of sense,
but specifying only Python 2.5.0?


> -1. I would prefer if there is only a single syntax for specifying
> version dependencies, independent of what metadata field they
> appear in.

That is admittedly a good argument.
-- 
Lennart Regebro: http://regebro.wordpress.com/
Python 3 Porting: http://python-incompatibility.googlecode.com/
+33 661 58 14 64


More information about the Python-Dev mailing list