[Python-Dev] Proposing PEP 345 : Metadata for Python Software Packages 1.2
david.lyon at preisshare.net
Tue Dec 29 00:09:54 CET 2009
On Mon, 28 Dec 2009 23:07:32 +0000, Michael Foord
<fuzzyman at voidspace.org.uk> wrote:
>> > Requires-Python: 2.5:2.7
>> Specifies a range of python versions.
> So this would work for Python 2.7 but *not* 2.7.1? Or does 2.7
> implicitly mean a range of all Python 2.7 versions?
Yes. 2.7 would mean all 2.7 versions. As 2.7.1 is a 2.7 release.
> If not how do we specify up to the last version of 2.6 (which may not
> yet be released) but *not* 2.7?
> 2.5:2.6.9 ?
No. As you might never know what the last release may ever be as
they keep on coming.
So like this:
> Requires-Python: 2.5:2.6
That will catch all 2.6 unreleased versions (security fixes et la)
and not 2.7
More information about the Python-Dev