[Python-Dev] Proposing PEP 345 : Metadata for Python Software Packages 1.2
ziade.tarek at gmail.com
Tue Dec 29 02:12:23 CET 2009
On Mon, Dec 28, 2009 at 9:26 PM, Tres Seaver <tseaver at palladion.com> wrote:
>> Requires-Dist: zope.interface (3.1.0) ==> only 3.1.0
> For completeness, isn't this really "any versino which starts with
> 3.1.0, not including post- or pre- releases"? That particular pacakge
> doesn't use more than a third version component, but there are packages
> in the wild which use four.
>> Requires-Python: 2.6.2 ==> only Python 2.6.2
> Here, the issue is only theoretical: Python dosn't issue "fourth dot"
Both points are right. I'll remove from the PEP the range operator and provide
a definition for 2.5 vs 2.5.x vs 2.5.0, as well as all these examples,
More information about the Python-Dev