[Python-Dev] ctime: I don't think that word means what you think it means.
steve at pearwood.info
Sun Jun 14 10:59:41 CEST 2009
On Sun, 14 Jun 2009 10:40:53 am Greg Ewing wrote:
> Zooko Wilcox-O'Hearn wrote:
> > 1. Add a "st_crtime" field which gets populated on filesystems
> > (Windows, ZFS, Mac) which can do so.
> "crtime" looks rather too similar to "ctime" for my
> liking. People who think that the "c" in "ctime"
> means "creation" are still likely to confuse them.
> Why not give it a more explicit name, such
> as "st_creationtime"?
Speaking as somebody who thought the c in ctime meant creation, I'm +1
on this proposal with Greg's modification.
More information about the Python-Dev