[Python-Dev] PEP 376

Nick Coghlan ncoghlan at gmail.com
Tue Jun 23 11:57:53 CEST 2009

Tarek Ziadé wrote:
> So what about :
> DistributionDirectory -> SiteDir
> DistributionDirectories ->  SiteDirMap

'site' has too many connections to existing concepts for my liking
(site.py, sitesetup.py, site-packages).

Something like DistributionDirectoryMap should cover it.

You could probably get away with shortening "Directory" to "Dir" in the
class names though:

 - Distribution
 - ZippedDistribution
 - DistributionDir
 - ZippedDistributionDir
 - DistributionDirMap

(Shortening Distribution to Dist might also be a possibility, but I
don't think that works well for the two basic classes, and if those use
the long form then shortening it for the *Dir and *DirMap classes would
just look odd)


Nick Coghlan   |   ncoghlan at gmail.com   |   Brisbane, Australia

More information about the Python-Dev mailing list