[Python-Dev] asyncore fixes in Python 2.6 broke Zope's version of medusa

glyph at divmod.com glyph at divmod.com
Thu Mar 5 10:58:54 CET 2009

On 4 Mar, 08:28 pm, barry at python.org wrote:
>Hash: SHA1
>On Mar 4, 2009, at 2:44 PM, glyph at divmod.com wrote:
>>Maintaining compatibility with the 2.6.x version of asyncore 
>>presupposes that *someone* has written some software against that 
>>version of asyncore and it might break if they installed an upgrade, 

>FWIW, I use smtpd.py and a few of the asyncore APIs  (.loop(), 
>.socket_map.clear(), and .close_all()) in the Mailman 3 test  suite. 
>That only works on Python 2.6 and I don't recall even a hiccup  when 
>moving from 2.5 to 2.6.

Well, in that case, I withdraw even my disinterested suggestion :).

More information about the Python-Dev mailing list