[Python-Dev] PEP 3144 review.

Antoine Pitrou solipsis at pitrou.net
Sun Sep 27 13:23:43 CEST 2009

Peter Moody <peter <at> hda3.com> writes:
> To be explicit though, unless I'm drastically misreading what you're
> asking for, I consider the design you're proposing to be broken from a
> usability perspective (striving for academic/pedantic correctness over
> accepted practice).

It is certainly not academic correctness, it is concern over the
understandibility of the library. The behaviour you are proposing is confusing,
and even if you think it is more practical (which I doubt it is), it should
still be avoided IMO. While "" may be an accepted notation in some
situations, it is not a notation for a *network* but for an (address, mask)
pair, or an (address, network) pair.

There was a proposal to have a separate parse_address_and_mask method which
would return a (Address, Network) tuple, I still don't know why you don't seem
to consider it seriously, rather than trying to make the Network class a kind of
all-in-one type conflating different concepts.



More information about the Python-Dev mailing list