[Python-Dev] PEP 389: argparse - new command line parsing module

Nick Coghlan ncoghlan at gmail.com
Mon Sep 28 14:37:16 CEST 2009

Steven Bethard wrote:
> I feel like I'm repeating the PEP, but here it is again anyway. There
> will be messages in the docs and pending deprecation warnings (which
> don't show up by default but can be requested) starting in Python 2.7
> and 3.2. Regular deprecation warnings wouldn't show up until Python
> 3.4, 3 years away. This compromise was intended exactly to address the
> issue you brought up about people getting over the Python 3
> transition.

For 2.x, I'd go even further and only have the PendingDeprecation
warnings show up under the "-3" command line flag.


Nick Coghlan   |   ncoghlan at gmail.com   |   Brisbane, Australia

More information about the Python-Dev mailing list