[Python-Dev] Proposed tweaks to functools.wraps
Nick Coghlan
ncoghlan at gmail.com
Wed Aug 11 14:28:55 CEST 2010
On Wed, Aug 11, 2010 at 8:45 PM, Antoine Pitrou <solipsis at pitrou.net> wrote:
> On Wed, 11 Aug 2010 12:30:40 +1000
> Nick Coghlan <ncoghlan at gmail.com> wrote:
>>
>> The second (#9396) came up in the context of the new cache decorators
>> added to functools, and allowing applications to choose their own
>> caching strategies. I suggested exposing the original (uncached)
>> function, and Raymond suggested that the easiest way to enable that
>> would be for functools.update_wrapper to add a new attribute that
>> provides a reference to the original function. Some time back, we
>> considered doing this automatically as an integral part of decoration,
>> but decided that wasn't appropriate. However, building it into the
>> explicit wrapping functions makes sense to me. To avoid namespace
>> conflicts, I plan to use "__wraps__" as the name for the reference to
>> the original function.
>
> I think it should be "__wrapped__".
Agreed, particularly since the relevant argument to update_wrapper()
is already called "wrapped".
Cheers,
Nick.
--
Nick Coghlan | ncoghlan at gmail.com | Brisbane, Australia
More information about the Python-Dev
mailing list