[Python-Dev] Distutils2 scripts

Eric Smith eric at trueblade.com
Thu Oct 21 14:01:27 CEST 2010

On 10/21/2010 4:44 AM, Antoine Pitrou wrote:
> On Wed, 20 Oct 2010 20:01:56 -0500
> Ron Adam<rrr at ronadam.com>  wrote:
>> On Ubuntu, I use python, python2.7, python3.1, python3.2 and that is what I
>> type to use that particular version.  The -m option seems to me to be the
>> easiest to do and works with all of these.
>>       python2.7 -m setup
>>       python3.2 -m setup
> Having pysetup or pysetupX.Y executables would be much more practical
> with shell auto-completion, though.

I agree. I also don't see any confusion about which python a 
"pysetupX.Y" would use. Or for that matter a plain "pysetup". It would 
be the one that a plain "python" would get you.


More information about the Python-Dev mailing list