[Python-Dev] A sad state of doctests in the python manual

Alexander Belopolsky alexander.belopolsky at gmail.com
Thu Oct 28 22:57:43 CEST 2010


On Thu, Oct 28, 2010 at 4:52 PM, Alexander Belopolsky
<alexander.belopolsky at gmail.com> wrote:
> On the second look, the problem may not be that bad ...

Nope, the problem is even worse.  It looks like Sphinx in py3k
requires 2.x python:

$ ../python.exe tools/sphinx-build.py -b doctest -d build/doctrees -D
latex_paper_size=  . build/doctest
Traceback (most recent call last):
  File "tools/sphinx-build.py", line 27, in <module>
    from sphinx import main
  File "tools/sphinx/__init__.py", line 44
    except ImportError, err:
                      ^
SyntaxError: invalid syntax


More information about the Python-Dev mailing list