[Python-Dev] terminology for "free variables" in Python
g.brandl at gmx.net
Fri Sep 10 22:46:12 CEST 2010
Am 10.09.2010 14:41, schrieb Nick Coghlan:
> On Fri, Sep 10, 2010 at 5:06 PM, Eli Bendersky <eliben at gmail.com> wrote:
>> Nick, did you know that dis.show_code is neither exported by default from
>> the dis module, nor it's documented in its help() or .rst documentation?
>> Neither is code_info(), which is used by show_code(). I wonder if this is
> code_info is in the normal documentation. I even remembered the
> versionadded tag without Georg reminding me ;)
> The omission from __all__ (and hence the module help text) was
> accidental and is now fixed.
> The omission of show_code from the documentation was deliberate, and
> I've now added a comment to that effect (the history is that
> dis.show_code has been around, but undocumented, for a while. The fact
> that it printed directly to stdout rather than producing a formatted
> string was mildly irritating, so I refactored the formatting part out
> into code_info, leaving just a single print call in show_code. Since I
> only kept show_code around for backwards compatibility reasons, I
> don't see any point in advertising its existence - better for people
> to just call code_info and print the result themselves.
> Although it *is* somewhat handy for quick introspection at the
> interpreter prompt... maybe I should document it after all. Thoughts?
IMO show_code() is not a good name, because the only thing it doesn't
do is to -- show the code.
I'd rather call it "codeinfo" (which also is more in line with current
dis module function names).
Thus spake the Lord: Thou shalt indent with four spaces. No more, no less.
Four shall be the number of spaces thou shalt indent, and the number of thy
indenting shall be four. Eight shalt thou not indent, nor either indent thou
two, excepting that thou then proceed to four. Tabs are right out.
More information about the Python-Dev