[Python-Dev] Fwd: Anyone still using Python 2.5?

Toshio Kuratomi a.badger at gmail.com
Thu Dec 22 06:17:32 CET 2011

On Thu, Dec 22, 2011 at 02:49:06AM +0100, Victor Stinner wrote:
> >Do people still have to use this in commercial environments or is
> >everyone on 2.6+ nowadays?
> At work, we are still using Python 2.5. Six months ago, we started a
> project to upgrade to 2.7, but we have now more urgent tasks, so the
> upgrade is delayed to later. Even if we upgrade new clients to 2.7,
> we will have to continue to support 2.5 for some more months (or
> years?).
At my work, I'm on RHEL5 and RHEL6.  So I'm currently supporting python-2.4
and python-2.6.  We're up to 75% RHEL6 (though, not the machines where most
of our deployed, custom written apps are running) so I shouldn't have to
support python-2.4 for much longer.

> In a personal project (the IPy library), I dropped support of Python
> 2.5 in february 2011. Recently, I got a mail asking me where the
> previous version of my library (supporting Python 2.4) can be
> downloaded! Someone is still using Python 2.4: "I'm stuck with python
> 2.4 in my work environment."
As part of work, I package for EPEL5 (addon packages for RHEL5).  Sometimes
we need a new version of a package or a new package for RHEL5 and thus need
to have python-2.4 compatible versions of the package and any of its

When I no longer need to maintain python-2.4 stuff for work, I'm hoping to
not have to do quite so much of this but sometimes I know I'll still get
requests to update an existing package to fix a bug or fix a feature and
that will require updates of dependent libraries.  I'll still be stuck
looking for python-2.4 compatible versions of all of these :-(

> >What do people feel?
> For a new project, try to support Python 2.5, especially if you would
> like to write a portable library. For a new application working on
> Mac OS X, Windows and Linux, you can only support Python 2.6.
I agree that libraries have a need to go farther back than applications.
I have one library that I support on python-2.3 (for RHEL4... I'm counting
down the months on that one :-).  Every other library I maintain, I make sure
I support at least python-2.4.

Application-wise, I currently have to support python-2.4+ but given that
Linux distros seem to all have some version out that supports at least
python-2.6, I don't think I'll be developing any applications that
intentionally support less than that once I get moved away from RHEL-5 at my

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://mail.python.org/pipermail/python-dev/attachments/20111221/031dc193/attachment.pgp>

More information about the Python-Dev mailing list