[Python-Dev] FYI: Python 2.7.1 + gcc 4.6 (experimental) probable optimizer problem

Stefan Krah stefan at bytereef.org
Sat Jan 8 22:58:51 CET 2011


Antoine Pitrou <solipsis at pitrou.net> wrote:
> On Sat, 8 Jan 2011 12:03:35 -0800 (PST)
> "Ralf W. Grosse-Kunstleve" <rwgk at yahoo.com> wrote:
> > I just wanted to share an observation in case Python developers are
> > interested:
> > Python 2.7.1 doesn't build with the current gcc 4.6 svn.
> > Note that gcc 4.6 is now in "bug-fix only" mode.
> 
> You should report a bug with the gcc developers.
> By the way, can you try to build Python 3.2 too?

I can reproduce this with release27-maint on Fedora-14/amd64/gcc-4.6.
-fno-strict-aliasing is enabled.

py3k is fine. Hard to tell if it's a gcc bug or not. gcc-4.6 increased
the ANSI compliance requirements yet again, exposing third party bugs
like this one:

http://sourceware.org/ml/libc-alpha/2010-12/msg00009.html


There is an issue for this:

http://bugs.python.org/issue9880


Stefan Krah




More information about the Python-Dev mailing list