[Python-Dev] build problem

Victor Stinner victor.stinner at haypocalc.com
Sun Jan 23 21:22:31 CET 2011

Le dimanche 23 janvier 2011 à 19:18 +0100, "Martin v. Löwis" a écrit :
> >     Adding an extra set of quotes around the command seems to fix
> > this. I've attached a patch.

Hey! I already wrote exactly the same patch! But I didn't propose it
upstream because I was unable to reproduce the bug.

> This is puzzling: a) AFAICT, the code works on all other system as it
> stands,

I had this issue already twice, but later (after a reboot? I don't
remember) it worked again (without the patch). It might be related to an
upgrade of TortoiseSVN (try to upgrade TortoiseSVN without rebooting).

> b) putting this many quotes into the command line is not plausible.

""c:\path\to\subwcrev.exe" arg1 arg2 ..." just works. I don't understand
why (strange syntax), but it works :-)

When I had the problem, it worked with extra quotes, but not without. It
is strange because the program ("c:\path\to\subwcrev.exe") existed!?


More information about the Python-Dev mailing list