[Python-Dev] [Python-checkins] cpython: Close #12028: Make threading._get_ident() public, rename it to

Victor Stinner victor.stinner at haypocalc.com
Tue May 31 10:51:45 CEST 2011

Le mardi 31 mai 2011 10:37:15, Nick Coghlan a écrit :
> I was just wrong, but the wording is still confusing since it has been
> copied from _thread.ident. "Thread" means something other than
> "threading.Thread" in that module, while in the threading docs, it
> typically refers to the actual objects. With the change of module,
> there needs to be something to make it clearer that this is
> information related to os level threads.

Yes, I copy-pasted the doc from Python 2.7, from thread.get_ident(). Feel free 
to edit directly the doc.


More information about the Python-Dev mailing list