[Python-Dev] PEP 418: rename time.monotonic() to time.steady()?

Lennart Regebro regebro at gmail.com
Tue Apr 3 16:13:44 CEST 2012


On Tue, Apr 3, 2012 at 13:26, Victor Stinner <victor.stinner at gmail.com> wrote:
> Hi,
>
> I would to rename time.monotonic() to time.steady() in the PEP 418 for
> the following reasons:
>
>  - time.steady() may fallback to the system clock which is not
> monotonic, it's strange to have to check for
> time.get_clock_info('monotonic')['is_monotonic']
>  - time.steady() uses GetTickCount() instead of
> QueryPerformanceCounter() whereas both are monotonic, but
> QueryPerformanceCounter() is not steady

Wait, what?
I already thought we, several days ago, decided that "steady" was a
*terrible* name, and that monotonic should *not* fall back to the
system clock.

It seems that we are going in circles with this. Now we are back to
where we started. Now we have a time.steady() which may not be steady
and a time.highres() which may not be high resolution.

//Lennart


More information about the Python-Dev mailing list