[Python-Dev] PEP 418: rename time.monotonic() to time.steady()?

Ethan Furman ethan at stoneleaf.us
Wed Apr 4 00:10:45 CEST 2012

Cameron Simpson wrote:
> Sigh. They're different things! For all that "steady" is a slightly
> vague term, steady and hires and monotonic are independent concepts. Of
> course a lot of high quality clocks will embody hires and ideally steady
> or monotonic.
> This kind of offer-just-one-thing embedded policy is why I feel the API
> needs more user control and a polciy free interface, with montonic() et
> al providing handy prepackaged policy for the common uses.



More information about the Python-Dev mailing list