[Python-Dev] PEP 418: rename time.monotonic() to time.steady()?

Mark Lawrence breamoreboy at yahoo.co.uk
Wed Apr 4 02:06:15 CEST 2012

On 04/04/2012 00:31, Cameron Simpson wrote:
> [ Returning at more leisure... ]
> I think Kristj\341n Valur J\363nsson is on point when he says "There is
> no such thing as steady time", but the notion is very attractive. If
> you're going to return a "steady" clock you should be able to find out
> how steady that is, for example in maximum step size (adjustment in
> alignment with "real time") in seconds. I think if I got 3600 from such
> a query I'd decide it was not steady enough and choose not to rely on
> it. (Or print all results output in blinking red text:-)
> Cheers,

IIRC time.steady() has been rejected umpteen times.  Someone (apologies, 
it's a long thread :) suggested time.steadier() [or time.steadiest() ?] 
implying that it's the best that can be done.  I'd go with that unless 
someboby has a better option, but there's been so many suggested that I 
might even have to read the PEP :)

The more that this thread runs, the more I get the impression that we're 
trying to make mountains out of electrons.  Having said that, I know 
that the conservative nature of Python development is the best approach 
here wrt the API.  Rather short term pain and long term gain than vice 

Just my 2p worth.


Mark Lawrence.

More information about the Python-Dev mailing list