[Python-Dev] PEP 418: rename time.monotonic() to time.steady()?

Lennart Regebro regebro at gmail.com
Wed Apr 4 17:30:26 CEST 2012

On Tue, Apr 3, 2012 at 23:14, Victor Stinner <victor.stinner at gmail.com> wrote:
>> Wait, what?
>> I already thought we, several days ago, decided that "steady" was a
>> *terrible* name, and that monotonic should *not* fall back to the
>> system clock.
> Copy of a more recent Guido's email:
> http://mail.python.org/pipermail/python-dev/2012-March/118322.html
> "Anyway, the more I think about it, the more I believe these functions
> should have very loose guarantees, and instead just cater to common
> use cases -- availability of a timer with minimal fuss is usually more
> important than the guarantees. So forget the idea about one version
> that falls back to time.time() and another that doesn't -- just always
> fall back to time.time(), which is (almost) always better than
> failing.

I disagree with this, mainly for the reason that there isn't any good
names for these functions. "hopefully_monotonic()" doesn't really cut
it for me. :-)
I also don't see how it's hard to guarantee that monotonic() is monotonic.


More information about the Python-Dev mailing list