[Python-Dev] time.clock_info() field names

Benjamin Peterson benjamin at python.org
Mon Apr 30 03:31:34 CEST 2012

2012/4/29 Jim J. Jewett <jimjjewett at gmail.com>:
> In http://mail.python.org/pipermail/python-dev/2012-April/119134.html
> Benjamin Peterson wrote:
>> I see PEP 418 gives time.clock_info() two boolean fields named
>> "is_monotonic" and "is_adjusted". I think the "is_" is unnecessary and
>> a bit ugly, and they could just be renamed "monotonic" and "adjusted".
> I agree with monotonic, but I think it should be "adjustable".

I don't really care, but I think "adjusted" is fine. As in "this clock
is adjusted (occasionally)".


More information about the Python-Dev mailing list