[Python-Dev] time.clock_info() field names
cs at zip.com.au
Mon Apr 30 13:06:16 CEST 2012
On 29Apr2012 21:31, Benjamin Peterson <benjamin at python.org> wrote:
| 2012/4/29 Jim J. Jewett <jimjjewett at gmail.com>:
| > In http://mail.python.org/pipermail/python-dev/2012-April/119134.html
| > Benjamin Peterson wrote:
| >> I see PEP 418 gives time.clock_info() two boolean fields named
| >> "is_monotonic" and "is_adjusted". I think the "is_" is unnecessary and
| >> a bit ugly, and they could just be renamed "monotonic" and "adjusted".
| > I agree with monotonic, but I think it should be "adjustable".
| I don't really care, but I think "adjusted" is fine. As in "this clock
| is adjusted (occasionally)".
-1 on "adjustable". That suggests the user can adjust it, not that the
OS may adjust it.
+1 on "adjusted" over "is_adjusted".
Cameron Simpson <cs at zip.com.au> DoD#743
Winter is gods' way of telling us to polish.
- Peter Harper <bo165 at freenet.carleton.ca> <harperp at algonquinc.on.ca>
More information about the Python-Dev