[Python-Dev] Python 2.7: only Visual Studio 2008?

Brian Curtin brian at python.org
Tue Aug 21 15:44:37 CEST 2012

On Tue, Aug 21, 2012 at 5:24 AM, Luc Bourhis <luc_j_bourhis at mac.com> wrote:
> Greetings,
> it is my understanding that the patches floating around the net to support Visual Studio 2010 to compile the Python core and for distutils will never be accepted and therefore that the 2.7 line is stuck to VS 2008 for the remaining of its life. Could you please confirm that?

This is correct. A compiler upgrade is a feature, so the change to
VS2010 could only be applied to the version actively receiving new
features, which at the time was 3.3.

More information about the Python-Dev mailing list