[Python-Dev] please back out changeset f903cf864191 before alpha-2

Antoine Pitrou solipsis at pitrou.net
Mon Aug 26 10:36:18 CEST 2013

Le Sat, 24 Aug 2013 14:42:24 -0400,
Terry Reedy <tjreedy at udel.edu> a écrit :
> >
> > And these for IncrementalParser:
> >
> >      data_received(data)
> >          Feed the given bytes data to the incremental parser.
> Longer, awkward, and to me ugly in comparison to 'feed'. Since it
> seems to mean more or less the same thing, why not reuse 'feed' and
> continue to build on people prior knowledge of Python?

Just because *your* prior knowledge of Python doesn't include
event-driven processing using network libraries, doesn't mean it's a
completely new and unknown thing to other people. There are reasons why
"data_received" is better (less ambiguous) than "feed".

If you want to influence tulip's design, however, this is the wrong
mailing-list to do so.

More information about the Python-Dev mailing list