[Python-Dev] please back out changeset f903cf864191 before alpha-2

Antoine Pitrou solipsis at pitrou.net
Mon Aug 26 18:21:05 CEST 2013

Le Mon, 26 Aug 2013 09:14:38 -0700,
Eli Bendersky <eliben at gmail.com> a écrit :
> Antoine, you opted out of the tracker issue but I feel it's fair to
> let you know that after a lot of discussion with Nick and Stefan (*),
> we've settled on renaming the input methods to feed & close, and the
> output method to read_events. We are also considering a different
> name for the class.

Fair enough.

> As for the class name, IncrementalParser is ambiguous because it's not
> immediately clear which side is incremental. Input or output?

Both are :-)

(which makes sense, really: an incremental input without output will
only yield a slight memory consumption benefit - only slight, since the
object tree representation should be much more costly than its bytes
serialization -; an incremental output without input doesn't seem to
have any point at all)



More information about the Python-Dev mailing list