[Python-Dev] please back out changeset f903cf864191 before alpha-2
eliben at gmail.com
Mon Aug 26 18:40:36 CEST 2013
On Mon, Aug 26, 2013 at 9:21 AM, Antoine Pitrou <solipsis at pitrou.net> wrote:
> Le Mon, 26 Aug 2013 09:14:38 -0700,
> Eli Bendersky <eliben at gmail.com> a écrit :
> > Antoine, you opted out of the tracker issue but I feel it's fair to
> > let you know that after a lot of discussion with Nick and Stefan (*),
> > we've settled on renaming the input methods to feed & close, and the
> > output method to read_events. We are also considering a different
> > name for the class.
> Fair enough.
> > As for the class name, IncrementalParser is ambiguous because it's not
> > immediately clear which side is incremental. Input or output?
> Both are :-)
Yes, exactly :-) "Incremental", though, seems to support the conjecture
that it's the input. Which is true, but, since XMLParser is also
"incremental" in this sense, slightly confusing.
As a more anecdotal piece of evidence: when the issue was reopened, I
myself at first got confused by exactly this point because I forgot all
about this in the months that passed since the commit. And I recalled that
when I initially reviewed your patch, I got confused too :-) That would
suggest one of two things: (1) The name is indeed confusing or (2) I'm
stupid. The fact that Nick also got confused when trying a cursory
understanding of the documentation cams me down w.r.t. (2).
Back to the discussion, my new favorite is NonblockingParser. Because its
input side is exactly similar to XMLParser, the "Nonblocking" in the name
points to the difference in output, which is correct.
As the popular quote says, "There are only two hard problems in Computer
Science: cache invalidation and naming things."
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Python-Dev